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Section 1: Introduction

This Upgrade Guide contains instructions on upgrading your legacy AccuRoute environment to AccuRoute Server 
v4.0. It is written for the Omtool Server administrators with detailed knowledge of AccuRoute, the Windows 
operating system and the LAN. 

About AccuRoute (1-1)

Supported upgrade environment (1-2)

About the upgrade (1-1)

Related AccuRoute 4.0 documentation (1-4)

About AccuRoute
AccuRoute is Omtool's award-winning document-handling platform that captures, converts, routes and archives both 
paper and electronic-based documents enabling fast, secure, simultaneous distribution of data to multiple destinations 
in multiple formats. Using AccuRoute, an organization can deliver information faster with more efficient work flows 
while reducing the cost, complexity and risk. 

About the upgrade
The steps involved in upgrading a legacy AccuRoute Server to AccuRoute v4.0 are as follows:

 Preparing the legacy AccuRoute Server for the upgrade. The following versions are qualified for 
upgrading to AccuRoute Server v4.0:

 AccuRoute Server v3.01

 AccuRoute Server v3.01 Feature Pack 6

 AccuRoute Server v3.01a Feature Pack 6

 AccuRoute Server v3.01 Roll Up 2

 Upgrading the following interfaces: AccuRoute Server, Remote Administrators, Remote AccuRoute 
Compose Components (Composers), Remote AccuRoute Connectors for DMS Libraries, Remote 
Embedded Directive Managers, Remote Modem Servers and clients.

 Configuring the AccuRoute Server if necessary.

 Verify that all existing licenses have been regenerated for the AccuRoute v4.0 licensing model.

Note The license model for AccuRoute Server v4.0 has changed and new licenses need to be generated prior 
to running the upgrade. Please contact Omtool support and sales with your licensing questions.
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Supported upgrade environment
The following sections list the supported operating systems, server, client, database and modem versions. Use the 
information as a checklist and ensure you have the supported versions before you start the upgrade.

Server Operating Systems

 Windows® 2008 R2 64 bit

 Windows 2003 SP2 64 bit

Databases

 Microsoft® SQL Server 2008

 Microsoft SQL Express 2008

Important Microsoft SQL 2005 is no longer supported. If you are using SQL 2005, Omtool requires 
that you upgrade to SQL 2008 or SQL Express 2008 prior to upgrading your AccuRoute 
Server. 

Modem boards

 Dialogic® Brooktrout® TR1034 or SR140 with Boston v6.x drivers

 Dialogic Brooktrout Trufax RoHS only with Boston v6.x drivers

Note Trufax board models that are older than those listed above are not supported. 

Omtool Server

 AccuRoute Server v3.01

 AccuRoute Server v3.01 Feature Pack 6

 AccuRoute Server v3.01a Feature Pack 6

 AccuRoute Server v3.01 Roll Up 2

Client Operating Systems

 Windows 2008

 Windows 2003 SP2

 Windows XP SP3 Professional

 Windows 7 

AccuRoute Desktop

 AccuRoute v3.0x
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Note AccuRoute Desktop versions older than v3.0x are not supported. 

Important information on Remote Administrators, Composers, 
AccuRoute Connectors for DMS Libraries, Embedded Directive 
Managers and Modem Servers
All systems in your environment must use the same version of AccuRoute. Therefore, when you decide to upgrade 
your legacy AccuRoute Server to AccuRoute v4.0, you must upgrade all systems that comprise your environment. 
This includes Remote Administrators, Remote Composers, Remote AccuRoute Connectors for DMS Libraries, 
Remote Embedded Directive Managers and Remote Modem Servers.

Important Once you upgrade the AccuRoute Server, all Remote Composers go off-line until you 
upgrade them.

Note about ObjectArchive™ database
If you are planning to set up and use ObjectArchive, verify that the system where you will install ObjectArchive meets 
the following hardware and software requirements.

 Windows NT domain computer that always runs in the same domain as the AccuRoute Server

 Dual core processor; 2 GHz; 4GB of RAM; RAID 5W with 100 GB of disk space; DVD-ROM drive; and 
Microsoft mouse or compatible pointing device 

 Windows 2008 R2 64 bit, 2003 Standard Edition SP2 64 bit

 MS SQL Server 2008 or MS SQL Express 2008

Note ObjectArchive must be installed on a system remote from AccuRoute Server. The SQL Server does not 
have to be the same one used for the AccuRoute Server databases.

Note about Remote AccuRoute Intelligent Device Client
When you upgrade your AccuRoute Server, you must upgrade all instances of the remote AccuRoute Intelligent 
Device Client in your environment. For instructions on installing, configuring and removing the remote client, consult 
the AccuRoute Server installation and integration guide. 

Note about Composers
When you install AccuRoute Server v4.0 as a new install, it creates one General Composer and one OCR Composer. 
This allows for the OCR Composer to be off-loaded more easily, freeing up valuable system resources.

http://www.omtool.com/documentation/AccuRoute/4.0/Server/AccuRouteV4.0ServerInstallConfigureGuide.pdf


AccuRoute Server and Clients Upgrade Guide

Section 1: Introduction

© 2013 by Omtool, Ltd. All rights reserved. Omtool, AccuRoute and the Company logo are trademarks of the Company. Trade names and trademarks of other companies appearing in this document are the property of their respective owners.

1-4

However, when you upgrade from a legacy server to AccuRoute Server v4.0, you may have only one instance of the 
Composer since the upgrade will not change your Composer configuration. You can add additional Composers, and 
configure a Composer to handle only OCR jobs. Contact Omtool Sales for more information. 

Note about AccuRoute clients 
The installation setup files for the AccuRoute clients are located in the Clients directory of the AccuRoute Server. 
After you have finished installing the AccuRoute Server, you must configure the Clients folder within the Omtool 
directory. This is necessary because systems which will install the AccuRoute Desktop and other clients remotely 
must have access to this folder containing the setup files. For instructions on how to configure the share, see 
Configuring the client install directory share (3-11). 

Note AccuRoute Desktop Clients v3.0x or higher are supported with AccuRoute Server v4.0. Therefore, if you 
have AccuRoute Desktop Clients v3.0x deployed in your environment, upgrading them to v4.0 is not a 
requirement. However, Omtool recommends that you upgrade to the latest version of AccuRoute 
Desktop client to take advantage of the latest features.

Important information about server clusters
AccuRoute is a cluster-aware application. If you plan to use the server cluster functionality after the upgrade, consult 
Appendix A: Setting up an AccuRoute Server cluster section in the AccuRoute Server Installation and Integration Guide 
for an overview of the clustering functionality and instructions on setting up the cluster. 

Note Read this upgrade manual in its entirety and plan your upgrade accordingly. If you have additional questions 
or require assistance in upgrading, contact Omtool support. 

Related AccuRoute 4.0 documentation
For more information about AccuRoute Desktop and other AccuRoute products, refer to the AccuRoute v4.0 
documentation home page to access:

 Readmes and release notes

 DMS Libraries quick start guides

 User guides and online help

 Administrator guides

 Installation and upgrade guides

http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
mailto:sales@omtool.com
mailto:sales@omtool.com
mailto:sales@omtool.com
http://www.omtool.com/documentation/AccuRoute/4.0/Server/AccuRouteV4.0ServerInstallConfigureGuide.pdf
http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
http://www.omtool.com/documentation/AccuRoute/4.0/Server/AccuRouteV4.0ServerInstallConfigureGuide.pdf
http://www.omtool.com/documentation/AccuRoute/4.0/Server/AccuRouteV4.0ServerInstallConfigureGuide.pdf
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Section 2: Preparing for the Upgrade

This section includes:

Verifying the version of your AccuRoute Server (2-1)

Preparing the AccuRoute Server (2-1)

Verifying the version of your AccuRoute Server
You can upgrade to AccuRoute Server v4.0 from the following AccuRoute versions:

 AccuRoute Server v3.01

 AccuRoute Server v3.01 Feature Pack 6

 AccuRoute Server v3.01a Feature Pack 6

 AccuRoute Server v3.01 Roll Up 2

Note If you are running AccuRoute v2.3, first upgrade to one of the v3.01 options above and then follow the 
instructions in this guide to upgrade to v4.0.

To check the version of your server:

1 Start the Omtool Server Administrator. 

2 In the console tree, right-click the AccuRoute Server name.

3 Select Properties from the drop-down menu.

The version is listed in the General tab of the Properties page. 

4 Verify that the version of the server is one of the AccuRoute v3.01 options listed above.

Preparing the AccuRoute Server
This section includes:

Verifying a Windows Active Directory environment (2-2)

Verifying that the DSN registry key contains an ODBC connection string (2-2)

Backing up the database (2-3)

Backing up the server (2-3)

Disabling the cleanup task (2-4)
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Backing up the templates (2-4)

Reviewing custom views (2-4)

Obtaining login credentials of the system running the AccuRoute Server (2-5)

Assigning distributed COM permissions (2-5)

Cancelling messages in the In Process Queue (2-5)

Verifying Internet Explorer Enhanced Security Configuration is disabled (2-6)

Enabling 8.3 Name Creation on NTFS Partitions (2-7)

Verifying fax board drivers (for servers with fax capability) (2-7)

Reviewing configuration data for the AccuRoute Connector for LexisNexis® Concordance® (2-7)

Embedded AccuRoute Device Clients (2-8)

Embedded AccuRoute Device Clients (2-8)

Backing up Cost Recovery custom configurations (2-8)

You must prepare the AccuRoute Server and the systems in the environment before you upgrade.

Verifying a Windows Active Directory environment
Before you proceed further, verify that the system where the AccuRoute Server is running has an active Windows 
Active Directory. This is of critical importance since AccuRoute v4.0 can only be installed in a Windows Active 
Directory environment. All server security and authentications are dependent on the Active Directory 
authentication.

Verifying that the DSN registry key contains an ODBC connection 
string
The database for the AccuRoute Server requires an ODBC connection. Before you upgrade, check the DSN registry 
key and verify that it contains a complete ODBC connection string (and not a reference to a predefined data source).

1 Click Start > Run to open a Windows command prompt. 

2 Enter regedit. Click OK.

The Registry Editor opens. 

3 Navigate to HKEY_LOCAL_MACHINE > Software > Omtool > Genifax > Current Version 
> DSN

4 Verify that the DB entry has a value beginning with Driver = {SQL Server}.

5 If necessary, build the connection string using the following syntax:

Driver={SQL Server}; Server=ServerName; Database=AccuRoute Server; 
UserID=""; Password="";

where, 

 Server is the name of the system where you installed the SQL Server.
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 Database is the name of the database. AccuRoute Server is the default database for 
AccuRoute Servers.

 UserID and Password are the login credentials to be used for the database authentication.

Note If you are using Windows authentication, use null values as shown above. If you are using SQL 
authentication, use appropriate values for user name and password.

6 In a text file, note down the database name used in this key. You will need to supply the database name 
while backing up the database. 

7 Close the registry editor.

Backing up the database

Important Before you upgrade, you must back up all the existing AccuRoute databases using the 
instructions below.

1 Log in to the system which has a given AccuRoute Server database.

2 Click Start > All Programs > Administrative Tools > Services. 

3 Locate all Omtool services.

4 Right-click each service and click Properties from the drop-down menu.

5 On the Properties page, go to the Startup type section and select Disabled from the drop-down 
menu.

6 Stop all Omtool services.

7 Using the Task Manager, verify that all Omtool processes (beginning with Om*) are stopped.

8 Click Start > Run to open a Windows command prompt. 

9 Back up the database using instructions provided by Microsoft in http://msdn.microsoft.com/en-us/
library/ms130214(SQL.90).aspx.

If necessary, change the name of the database while backing it up. You can also change the name of the 
backup file and the file path. 

10 Locate the Omtool services and set the Startup Type to Automatic.

11 Start all Omtool services.

Backing up the server
Before you upgrade, you must back up the server in addition to backing up your database. For information on how 
to backup your server, log in to the Omtool Knowledge Base using your customer number and see this article: 
https://www.omtool.com/support/kbArticle.cfm?aID=1431.

http://msdn.microsoft.com/en-us/library/ms130214(SQL.90).aspx
http://msdn.microsoft.com/en-us/library/ms130214(SQL.90).aspx
http://msdn.microsoft.com/en-us/library/ms130214(SQL.90).aspx
http://msdn.microsoft.com/en-us/library/ms130214(SQL.90).aspx
http://msdn.microsoft.com/en-us/library/ms130214(SQL.90).aspx
https://www.omtool.com/support/kbArticle.cfm?aID=1431
https://www.omtool.com/support/kbArticle.cfm?aID=1431
https://www.omtool.com/support/kbArticle.cfm?aID=1431
https://www.omtool.com/support/kbArticle.cfm?aID=1431
http://msdn.microsoft.com/en-us/library/ms130214(SQL.90).aspx
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Disabling the cleanup task
Before you upgrade, you must disable the cleanup task so that it cannot run during the server upgrade.

1 Open the Server Administrator.

2 Click Start > All Programs > Omtool > Omtool Server Administrator to open the 
Administrator. 

3 Expand the console tree and click Components.

4 Double-click the Maintenance component to open the Properties page. 

5 Click Advanced to open the Maintenance Advanced Properties page.

6 Click Schedule. 

A popup opens prompting you to provide the username and its associated password.

7 Enter the user name and password that was provided during server installation. 

8 Clear the Enabled (scheduled task runs at specified time) option. 

9 Click OK and then OK again to save your changes. 

Backing up the templates
The setup program for the server upgrade overwrites all the files in these directories. Before you upgrade, you must 
back them up prior to running the server upgrade. 

1 Make a backup copy of the Templates directory.

The Templates directory is located in: 
C:\program Files\Omtool\Omtool Server\Languages\ENU\Templates where C: 
is the drive where the AccuRoute Server is installed.

2 Make a backup copy of the Embedded Directives directory.

This directory is located in:
C:\program Files\Omtool\Omtool 
Server\Languages\ENU\EmbeddedDirectives where C: is the drive where the 
AccuRoute Server is installed.

Note These directories contain cover page templates, routing sheet templates, and notification templates for 
your server. 

Reviewing custom views
Before you upgrade, it is recommended that you review your custom views and note the criteria you used to create 
them.

Important This is a necessary step without which you will not be able to recreate them, if necessary, 
after the server upgrade.



© 2013 by Omtool, Ltd. All rights reserved. Omtool, AccuRoute and the Company logo are trademarks of the Company. Trade names and trademarks of other companies appearing in this document are the property of their respective owners.

2-5AccuRoute Server and Clients Upgrade Guide

Section 2: Preparing for the Upgrade

To locate your custom views:

1 Click Start > All Programs > Omtool > Omtool Server Administrator to open the 
Administrator.

2 In the console tree, expand the Server Administrator node and select Messages.

Both In Process and History are standard system views. Any other options you see under 
Messages are Custom Views.

Obtaining login credentials of the system running the AccuRoute 
Server
During the server upgrade, the setup program prompts you for login credentials of the server account. (This is the 
same account you used to install the AccuRoute Server.) Before you upgrade, make a note of the login credentials 
of the system running the server. 

Assigning distributed COM permissions
The AccuRoute Server requires that the server account and other system-related accounts have particular 
Distributed COM permissions. Before you upgrade, verify that the proper DCOM permissions are configured. 

Configuring DCOM permissions on Windows 2008 and on Windows 2003

If you are using a Remote AccuRoute Intelligent Device Client, you must add Anonymous to the list of users and give 
the Anonymous user access, launch and activation permissions. For details, consult the AccuRoute Server Installation 
and Integration Guide. 

1 Log in to the system where you will install AccuRoute Server using the login credentials of the local 
Administrators group. 

2 Click Start > Run. Enter dcomcnfg and click OK. The Component Services snap-in opens.

3 Expand Component Services > Computers. Right-click My Computer and select Properties 
from the menu options. 

4 Click the COM Security tab.

5 Under Launch and Activation Permissions, click the Edit Limits button, and then click the Add 
button.

6 Add Anonymous Logon in the Permissions list, select the Allow check box to allow the Local 
Launch permission, Local Activation permission, Remote Launch permission, and Remote 
Activation permission for the selected group.

7 Click OK twice to save changes. 

8 Restart the system for these configuration changes to take effect. 

Cancelling messages in the In Process Queue
When preparing for the upgrade, you must wait for all messages to complete or cancel all messages in the In Process 
queue. 

http://www.omtool.com/documentation/accuroute/v3.01/Server/AccuRouteV301ServerInstallConfigureGuide.pdf
http://www.omtool.com/documentation/accuroute/v3.01/Server/AccuRouteV301ServerInstallConfigureGuide.pdf
http://www.omtool.com/documentation/accuroute/v3.01/Server/AccuRouteV301ServerInstallConfigureGuide.pdf
http://www.omtool.com/documentation/accuroute/v3.01/Server/AccuRouteV301ServerInstallConfigureGuide.pdf
http://www.omtool.com/documentation/accuroute/v3.01/Server/AccuRouteV301ServerInstallConfigureGuide.pdf
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Note Any message located in the In Process queue at the time of the upgrade fails to compose; the message 
journal indicates that. 

You must also notify AccuRoute users that they cannot send documents and faxes until the server upgrade and 
configuration is complete. It is recommended that you upgrade the server during off hours or when the volume of 
documents and faxes is low. 

To cancel messages in the In Process queue:

1 Click Start > All Programs > Omtool > Omtool Server Administrator to open the 
Administrator. 

2 Expand the console tree and go to Messages > In Process.

3 In the Details pane, select All Items in the View menu.

4 Select all the items in the list. Right-click and select Cancel from the drop-down options.

You are prompted to confirm or cancel the operation.

5 Click Yes.

Verifying Internet Explorer Enhanced Security Configuration is 
disabled
Verify that the Internet Explorer Enhanced Security Configuration is disabled. 

Note You cannot upgrade to AccuRoute v4.0 if the Internet Explorer Enhanced Security Configuration is 
enabled. If it is enabled in your system, disable it and reboot the system before proceeding with the 
upgrade. 

1 Click Start > Control Panel > Add or Remove Programs. 

2 In the Add or Remove programs page, click Add/Remove Windows Components. The 
Windows Component wizard opens. 

3 Scroll down the Components list to find Internet Explorer Enhanced Security Configuration.

4 Verify that the component is disabled. If it is enabled, disable the component.

5 Manually start the SQL service. 

Important When Internet Explorer Enhanced Security Configuration is disabled, the SQL service 
stops automatically. You must start the service before you can upgrade. 

6 Reboot the system. 
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Enabling 8.3 Name Creation on NTFS Partitions
You must enable 8.3 Name Creation on NTFS Partitions to allow Ghostscript to work with long filenames or with 
spaces/odd characters in the filename during conversion.

1 Click Start > Run. 

2 In the Open text box enter regedit to open the registry editor.

3 Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem.

4 Right click the NtfsDisable8dot3NameCreation entry and select Modify from the drop-down 
menu.

5 The Edit DWORD Value page opens.

6 In the Value data text box, enter 0.

7 Click OK to close the page. 

Verifying fax board drivers (for servers with fax capability)
The upgrade supports all new fax board drivers/modules for all supported fax boards including Dialogic Brooktrout 
Technology SR140, TR1034 series, and TruFax RoHS series. It is recommended that you update the drivers for your 
fax boards during an upgrade. 

The supported fax board drivers are:

 Dialogic Brooktrout TR1034 or SR140 with Boston v6.x drivers

 Dialogic Brooktrout Trufax RoHS only with Boston v6.x drivers

Important Non-RoHS TruFax boards are not supported in AccuRoute v4.0.

Reviewing configuration data for the AccuRoute Connector for 
LexisNexis® Concordance®

If you are using a AccuRoute Connector for LexisNexis Concordance, review and note the configuration details. 

You will need this data to reconfigure the connector after the server upgrade. 

Note If you are using AccuRoute Connector for CT Summation or AccuRoute Connector for FTI® Ringtail™, 
no review or reconfiguration is needed after the upgrade.

Note about Litigation Support Interface for CT Summation 

There is no automatic upgrade of the old AccuRoute Connector for Summation. After the upgrade, you must 
manually remove the old connector and create a new connector with the old configuration details. 
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Embedded AccuRoute Device Clients
All of the Embedded AccuRoute device clients must be uninstalled and reinstalled after the upgrade. Refer to the 
AccuRoute v4.0 documentation home page for detailed device client installation instructions for the following clients:

 HP OXPd v1.4

 HP OXPd v1.6

 Ricoh ESA v1.4

 Xerox EIP v1.2

Backing up Cost Recovery custom configurations
If you are upgrading your server and have Cost Recovery installed, you will need to uninstall and reinstall the Cost 
Recovery client. However, when you uninstall Cost Recovery, you loose all previous custom configurations. To keep 
these configurations and use them in the new Cost Recovery client, backup of the following files:

 CostRecovery.txt

 LFAccounting.ini

 LFCostRecovery.ini

 LFCostRecoveryU.ini

Additionally, if you want to keep previous data and if the file is not set to overwrite the previous record you should 
keep the cr.txt file.

http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
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Section 3: Applying the Upgrade

This section includes:

Downloading the server upgrade kit (3-1)

Upgrading the AccuRoute Server (3-1)

Entering a license for the AccuRoute server (3-6)

Upgrading Remote Administrators, Composers, AccuRoute Connectors for DMS Libraries, Embedded 
Directive Managers and Modem Servers (3-10)

Configuring the client install directory share (3-11)

For information on how to upgrade AccuRoute Servers that are part of a cluster, see Upgrading AccuRoute Servers 
in a Cluster (A-1).

Downloading the server upgrade kit
1 Go to http://www.omtool.com/support.

2 Log in using your customer number.

3 Locate the module in the Downloads & Docs section.

4 Download the module and save it to a local drive.

5 Extract the files to a location on your AccuRoute Server.

Upgrading the AccuRoute Server

Important The upgrade installs with a 30-day trial license. This license is watermarked and may not 
enable all of the functionality currently being used. Please contact Omtool support and 
sales to obtain permanent licensing for the purchased environment.

1 Close all applications on the server.

2 Navigate to the directory where you saved the download. 

3 Run setup.exe. 

http://www.omtool.com/support
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Note If you do not have an internet connection, you will see the following message: 
Failed to determine the latest version of the Prerequisite checking 
package
-2147012889: The server name could not be resolved.
Click OK to continue with the upgrade. 

The InstallShield Wizard configures your system, detects a prior version of the server and the 
Welcome page appears.

Note During the installation, if a dialog box indicates that a running application needs to be closed before you 
proceed, close the running applications. Click Retry and proceed with the installation.
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4 Click Next. The Command Prompt window may appear temporarily as the setup program stops the 
Omtool Address Book Manager service. The License Agreement page appears. 

5 Read the license agreement and click the button beside the I accept the terms of the license 
agreement option. Click Next. 

The setup checks the system for installation requirements and displays the results.

6 Review the results and click Next. 
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The setup requests logon credentials for the Omtool service account. 

7 Provide the logon credentials of the Omtool service account:

 In the NT Domain text box, enter the domain name.

 In the User Name text box, enter the user name.

 In the Password and Confirm Password text boxes, enter the password for the user.

8 Click Next.

The Ready to Install page opens listing all the installation settings. 

9 Review the installation settings. Click Next to begin the server upgrade. 
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The InstallShield Wizard upgrades the server. When the upgrade is complete, the InstallShield 
Wizard Complete page appears.

10 Click Finish to close the InstallShield wizard. 

The Server Configuration Wizard launches and the Welcome page appears.
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11 Click Next. You are prompted to save the changes you made to the server configuration. 

12 Click Finish. 

The Server Configuration Wizard saves your changes to the server configuration. The Omtool 
Server Administrator starts automatically.

13 Check the version of the server. The version should be v4.0.

Entering a license for the AccuRoute server

Note The AccuRoute server requires a license. For more information, contact Omtool Sales. 

You can activate the AccuRoute server license in one of two ways:

 Automatically when you enter an activation code and the AccuRoute server is on a system that has 
access to the internet.

 Manually if the AccuRoute server does not have access to the internet. In this case, you will:

 Submit and validate the activation code.

 Create an Export file into which the activation code is copied.

 Create an Import file and use this file for activation from a system that does have internet access.

Automatic license activation
Be sure the AccuRoute server has access to the internet. Have available a copy of the activation code.

1 Click Start > All Programs > Omtool > AccuRoute Server > AccuRoute Server 
Administrator.

2 Expand the tree view and select the server name.

3 Right-click and select the Licensing option. The Licensing page is displayed.
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4 Click the Activate License... button. The License Activation page is displayed.

5 Select the Automatically activate via the Internet option.

6 Enter your license activation code in the Activation Code text field.

7 Click OK. The server is updated with your license.

8 Click Close to complete the procedure.

Manual license activation
Have available a copy of the activation code.

Note Although the AccuRoute server may not have access to the internet, to complete this procedure you will 
need a system that does have access.

1 Click Start > All Programs > Omtool > AccuRoute Server > AccuRoute Server 
Administrator.

2 Expand the tree view and select the server name.

3 Right-click and select the Licensing option. The Licensing page is displayed.

4 Click the Activate License... button. The License Activation page is displayed.

5 Select the Export activation file for manual activation option.

6 Create an Export license file:

a Browse to a location where you want to save the license file. By default, the file is an Export file 
named ManualActivation.exp. After specifying the file name and location, click Save.

b The path will appear in the Export Filename field on the License Activation page. Click OK.

7 From a system with internet access, launch the web browser and go to:

https://license.omtool.com/accuroute
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The Manual Licensing Portal page opens.

8 Enter your license activation code in the Activation Code text field.

9 Be sure the Activate License option is selected (the default).

10 Click the Browse button to select the ManualActivation.exp file created in Step 6. With the 
file name selected (highlighted), click Open.

11 Verify that the license information is entered correctly on the Manual Licensing Portal page.
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12 Click NEXT and the Activation Successful message is displayed.

13 To complete the activation, click Download. The File Download page is displayed.

14 Click Save to create the Import file. By default, the file is named with the activation code. You can 
change this (for example, ManaulActivation.imp) and select a location for the file on the 
AccuRoute server.

15 Click Save. The Download Complete page shows that status of the file download.

16 Click Close.

Note You can minimize or close the browser.

17 On the Licensing page, click the Activate License... button.

18 Select the Import activation file from manual activation option.

19 Browse to the saved ManaulActivation.imp file. Select the file and click Open.

20 Click OK on the License Activation page. The license is updated.

21 Click Close to complete the procedure.
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Upgrading Remote Administrators, Composers, 
AccuRoute Connectors for DMS Libraries, Embedded 
Directive Managers and Modem Servers
Before you upgrade your Remote Administrator, Composer, AccuRoute Connector for DMS Libraries, Embedded 
Directive Manager or Modem Server, configure the appropriate Distributed COM permissions for the service 
account on the system where the remote component is installed. For instructions, see Assigning distributed COM 
permissions (2-5).

To upgrade Remote Administrators, Components, Connectors or Modem Servers:

1 Log in to the system where you are performing the upgrade. 

2 Open Windows Explorer and navigate to the folder where you saved the upgrade download. 

Note The folder where you saved the download must be shared so that the setup files are accessible from 
remote systems.

3 Run setup.exe. The Welcome message appears in the InstallShield wizard. 

4 Click Next. The License Agreement page opens. 

5 Read the license agreement and click the button beside the I accept the terms of the license 
agreement option. Click Next. The Omtool Server User page opens.

6 Enter the following information:

 In the NT Domain text box, enter the domain name.

 In the User Name text box, enter the user name.

 In the Password and Confirm Password text boxes, enter the password.

Note The login credentials you specify here must be same as those used on the AccuRoute Server from where 
the components are called. 

7 Click Next. The Installation Settings page opens. 

8 Review the installation settings. Click Next to begin remote component upgrade. 

The InstallShield Wizard upgrades the remote component. When the upgrade is complete, the 
InstallShield Wizard Complete screen appears.

9 Click Finish. 

10 Restart your computer.

Important If you upgraded a Remote Administrator, proceed to Connecting a Remote Administrator 
to the server. 
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Connecting a Remote Administrator to the server

The Administrator supports any combination of AccuRoute Servers. 

To launch the Administrator and connect to a server:

1 Click Start > All Programs > Omtool > Omtool Server Administrator. The Specify 
Omtool Message Server page opens.

2 Enter the name or IP address of the AccuRoute Server in the Network Address text box. 

3 Click Finish. The Omtool Server Administrator starts. 

Important If you have more than one server in your environment, type the name of any server in the 
Network Address text box—you can connect to additional servers once the 
Administrator starts.

If you want to connect to another server:

1 Right-click the Omtool Server Administrator in the console tree. Select Connect. The Specify 
Omtool Message Server page opens. 

2 Enter the name or IP address of the AccuRoute Server in the Network Address text box. 

3 Click Finish.

The server appears in the console tree under Omtool Server Administrator.

Configuring the client install directory share
After you finish upgrading the AccuRoute Server, you must configure the Clients folder within the Omtool 
directory located in the Program Files folder. This is necessary because the systems on which you will remotely 
install the AccuRoute Desktop and other clients must have access to this folder containing the setup files.

Note If you had a shared folder prior to the upgrade, share permissions for everyone except for the user 
account used are lost during the upgrade. To configure share permissions for everyone and not just the 
user account used during the upgrade, complete the procedure below. 

To configure sharing:

1 Navigate to the \Omtool\Omtool Server\Clients directory on the drive where you 
previously installed the AccuRoute Server.

2 Right-click Clients and select Sharing and Security from the drop-down menu.

3 Select the Share this folder option.

4 Select Permissions and verify that user Everyone is listed with read access.

5 Click OK then Apply to save your changes. 
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Section 4: Required Tasks after Upgrading

This section includes:

Copying templates to the server (4-1)

Resending cancelled messages (4-1)

Providing a logon account for the cleanup task (4-2)

Other configurations (4-2)

Copying templates to the server
Before running the server upgrade, you made a backup copy of the Templates and EmbeddedDirectives 
directories. See Backing up the templates (2-4) for more information.

Now copy these directories to the following locations on the AccuRoute Server: 

 Copy Notifications (body and subjects) to:

\Omtool\Omtool Server\Languages\ENU\Notifications

 Copy CoverPages to:

\Omtool Server\Languages\ENU\Coverpages

 Copy Distribution Routing Sheet templates to: 

\Omtool Server\Languages\ENU\EmbeddedDirectives

Resending cancelled messages
Before running the server upgrade, you cancelled all messages in the In Process folder. For more information, see 
Cancelling messages in the In Process Queue (2-5). 

Resend the messages you cancelled using the procedure below.

1 Start the Omtool Server Administrator.

2 Expand Messages in the console tree. Click History.

3 Click the radio button below the Cancelled barometer.

4 Go to the details pane and select All Items in the View menu.

5 Select all items in the list, right-click and select Resend.

6 Click OK to resend these messages.
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Providing a logon account for the cleanup task
Before running the server upgrade, you disabled the cleanup task so that it could not run during the server upgrade. 
For more information, see Disabling the cleanup task (2-4).

Re-enable the cleanup function by providing the login credentials for the task. Because the cleanup task modifies the 
AccuRoute database, it requires the same login credentials as the server account.

1 Start the Omtool Server Administrator.

2 Click and expand Components in the console tree. 

3 Double-click Maintenance in the details pane.

4 Click Advanced. The Maintenance Advanced Properties page opens.

5 Click Schedule. The Enter Account Information page opens.

6 In the Username textbox, enter the user name. In the Password and Confirm password text 
boxes, enter the password. 

7 Click OK, OK and OK to save your changes. 

Other configurations
After upgrading to AccuRoute v4.0, you must configure the connectors and components in your environment as 
necessary. For example, if you are using a remote Modem Server, you must re-detect Telco channels after the 
upgrade. Depending on your environment and needs, you may need to perform all or none of the configurations listed 
below. 

Important Be sure to review and note current configurations before proceeding with the upgrade 
process.

Enabling Notes after the upgrade
If you are using AccuRoute Connector for IBM® Lotus® Notes in your environment, all communication to and from 
the AccuRoute server is directed through the AccuRoute Connector for SMTP.

Modifying AccuRoute Server configuration after upgrade
After you upgrade your legacy AccuRoute Server, if you modify the server configuration, your actions will not remove 
the associated program files nor does it stop and remove associated services. For example, if you uninstall the Modem 
Server after an upgrade, it does not remove associated program files or stop/remove modem services. They will 
remain until a complete uninstallation is done. 
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Reconfiguring AccuRoute Connector for LexisNexis Concordance
If you are using AccuRoute Connector for LexisNexis Concordance in your environment, you must reconfigure the 
connector after upgrading and adding the permanent license for the Litigation Support connector. The AccuRoute 
Connector for LexisNexis Concordance contains a different configuration and implementation, requiring the 
connector to be reconfigured.

Note the configuration details before the upgrade and use that data to reconfigure the connector. See Reviewing 
configuration data for the AccuRoute Connector for LexisNexis® Concordance® (2-7) for details.

Reconfiguring conversion engine selection

Note Because modified conversion engine selections are lost during the upgrade, it is recommended that you 
review your current conversion engine selections and note the criteria you used to create them before 
upgrading to AccuRoute v4.0.

Modified conversion engine selections are not retained during the upgrade process. After upgrading from a legacy 
AccuRoute Server system to AccuRoute v4.0, reconfigure the conversion engines selected for particular file types.

For example, you may have previously selected Word Automation as the conversion engine for DOC files. The post-
upgrade conversion engine for DOC files is changed to Aspose (Aspose). Therefore, you may need to reconfigure 
the default compose engines. For information on how to configure a conversion engine for file types, consult the 
Omtool Server Administrator help. 

Redetecting Telco channels

Note Because all channel configurations are lost during the upgrade, it is recommended that you review your 
current channel configurations and note the criteria you used to create them before upgrading to 
AccuRoute v4.0.

All channel configurations are lost during the upgrade process. After upgrading from a legacy AccuRoute Server 
system to AccuRoute v4.0, redetect the Telco channels in order to reconfigure them. For information on how to 
detect channels, consult the Omtool Server Administrator help.

http://www.omtool.com/documentation/omtoolserver/4.0/admin/index.htm
http://www.omtool.com/documentation/omtoolserver/4.0/admin/index.htm
http://www.omtool.com/documentation/omtoolserver/4.0/admin/index.htm
http://www.omtool.com/documentation/omtoolserver/4.0/admin/index.htm
http://www.omtool.com/documentation/omtoolserver/4.0/admin/index.htm
http://www.omtool.com/documentation/omtoolserver/4.0/admin/index.htm
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This section includes:

Updating Fax board drivers (for servers with fax capability) (5-1)

Downloading latest Dialogic Brooktrout drivers (5-1)

Installing Dialogic Brooktrout v6.5.0 x64 drivers (5-2)

Configuring Dialogic Brooktrout SR140 (5-3)

Updating Fax board drivers (for servers with fax capability)
The upgrade supports all new fax board drivers/modules for all supported fax boards including Dialogic Brooktrout 
Technology SR140, TR1034 series, and TruFax RoHS series.

Note It is recommended that you update the drivers for your fax boards. 
If an Omtool Technical Support representative instructs you to update your drivers, use the procedures 
in this section to remove the drivers and then install new drivers.

Important Non-RoHS TruFax boards are not supported in AccuRoute v3.01 or AccuRoute v4.0.

Downloading latest Dialogic Brooktrout drivers
To download Dialogic Brooktrout v6.5.0 x64 drivers:

1 Go to http://www.omtool.com/support and log in using your customer number.

2 In the navigation pane on the left, click Support > Downloads and Docs.

3 Open the AccuRoute menu, go to Drivers section. Locate the download.

4 Click the download link to begin the download.

The zip file containing the .msi file and the Release Notes opens.

5 Select the files and click Extract. Browse to the location where you want to save the file.

6 Click Extract. The files are extracted and saved to the location you specified.

7 Name this directory the Boston directory.

http://www.omtool.com/support
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Installing Dialogic Brooktrout v6.5.0 x64 drivers
1 Locate the Boston directory. 

2 Double-click Brooktrout 6.5.0_x64.msi. The Welcome page opens. 

3 Click Next. The License Agreement page opens. 

4 Read the license agreement and select the I accept the terms in the license agreement option. 

5 Click Next. The Destination Folder page opens.

6 Modify the destination location if necessary and click Next. 

7 Click Next to begin the installation.

8 When installation is complete, you the InstallShield Wizard Completed page opens.

9 Click Finish. The Readme opens.

Activating the License

Note If you already have a working license, this step is not necessary.

Also note, the following procedure is applicable for SR140 modules only.

To activate the license:

1 Click Start >Program Files > Brooktrout License Manager. 

The BrookTrout License Manager opens.

2 In the menu bar, click License >Activate License. The License Activation wizard opens and the 
Welcome message appears.

3 Click Next. Select Using the interactive web method. 

4 Click Next. You get the Node Lock value. 

5 Click Save the instructions into a file option.

6 Click Next. 

7 Browse and save the file to a known location. 

8 Go to the location where you saved the file. Open the file.

The file contains text similar to that shown below and provides the Node Lock value of your system:

To request a license, please visit our website:

http://www.dialogic.com/activation

and follow the instructions provided on the website.

Dialogic will email the license to you immediately.

When prompted, supply the following information:
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Node Lock: [Node Lock value]

9 Open Internet Explorer and go to http://www.dialogic.com/activation.

10 In the License Key text box, enter the License key and the Node Lock value of your system. 

Important For the license key, contact Dialogic customer support. 

Dialogic sends you the license for your BrookTrout SR140 module.

Note This license key enables the Dialogic Brooktrout SR140 fax feature on the system from which the node 
value was retrieved. It cannot be transferred without assistance from Dialogic.

11 Save the license file to the local drive of the system. 

Applying the license

Note The following procedure is applicable for SR140 modules only.

To apply the license:

1 Launch the Brooktrout License Manager.

2 Select File > License.

3 Select Install License from the drop-down menu.

4 Browse to the license file you saved on the system.

Configuring Dialogic Brooktrout SR140
For configuration instructions, see section 4 of the Modem Driver Installation and Configuration Guide.

http://www.omtool.com/documentation/AccuRoute/4.0/Modem/ModemDriverInstallConfigurationGuide.pdf
http://www.omtool.com/documentation/AccuRoute/4.0/Modem/ModemDriverInstallConfigurationGuide.pdf
http://www.cantata.com/activation
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Section 6: Upgrading Client Applications

This section includes:

AccuRoute Desktop Client requirements (6-1)

AccuRoute Web Client (6-2)

Cost Recovery client (6-2)

FaxCenter client (6-3)

AccuRoute Desktop client (6-4)

All client installation setup files are located in the Clients directory of the AccuRoute Server. Before rolling out 
the client upgrade, you can share this Clients directory so that it is easily accessible from remote systems where 
the clients are installed. For instructions on how to share the Clients directory containing the setup files, see 
Configuring the client install directory share (3-11).

AccuRoute Desktop Client requirements
The system where you install/upgrade the AccuRoute Desktop client must meet the following requirements:

 Pentium®-class processor

 Windows 2008/2003 SP2/ XP Professional/Windows 7

 20 MB hard disk space

 64 MB RAM (128 recommended)

 Acrobat® Reader® 7.x (minimum)

Supported e-mail applications

 Microsoft® Outlook® 2007 (Outlook Express not supported)

 Notes 6.5/6.0/5.0

 Novell GroupWise 6.0/5.5

When the client is configured to integrate with an address book for a supported e-mail application, the e-mail 
application must be selected as the Windows default e-mail application. For more information, consult Windows 
help.
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AccuRoute Web Client
When you upgrade your AccuRoute Server, upgrade all instances of the AccuRoute Web Client in your environment. 
For more information, consult the AccuRoute Web Client Installation Guide and the Web Client User Guide.

Note about Omtool Web Client

Omtool Web Client was deprecated in AccuRoute v2.3. It was replaced by AccuRoute Web Client v2.0. Omtool 
recommends that when you upgrade to AccuRoute Server v4.0, you install and configure the AccuRoute Web Client 
v4.0. 

Important If you have a prior version of the Omtool Web Client, do not uninstall or remove the 
deprecated Omtool Web Client application and set up files in your system, as deleting 
those files may interfere with the server usage. 

Note You cannot configure the AccuRoute Server to use both the deprecated Omtool Web Client and the new 
AccuRoute Web Client at the same time. 

To upgrade the AccuRoute Web Client, refer to the AccuRoute v4.0 documentation home page to access upgrade 
instructions.

Cost Recovery client
When you upgrade your AccuRoute Server, upgrade all instances of the CostRecovery client in your environment. 
For more information on the CostRecovery application, consult the CostRecovery Administrator Guide.

To upgrade CostRecovery:

1 Click Start > Control Panel > Add/Remove Programs. Remove the existing version of 
CostRecovery from the system.

2 Open Windows Explorer and navigate to \\Servername\Clients\CostRecovery. 

where Clients is the network share folder containing the installation setup files. You must have 
configured this folder to give everyone access to the folder.

3 Run setup.exe. 

The InstallShield Wizard configures the system for the CostRecovery client and the Welcome 
message appears.

4 Click Next. The License Agreement page opens. 

5 Read the license agreement. Click Yes. The Choose Destination Location page opens. 

6 Click Next to accept the default destination location. Alternately, to install the application in a 
different location, click Browse. Navigate to the desired directory. Click OK and then Next.

The Genifax Server page opens. 

http://www.omtool.com/documentation/AccuRoute/4.0/AccuRouteWebClient/AccuRouteWebClientInstallConfigGuide.pdf
http://www.omtool.com/documentation/AccuRoute/4.0/AccuRouteWebClient/UserHelp/WebHelp/AccuRouteWebClient.htm
http://www.omtool.com/documentation/AccuRoute/4.0/AccuRouteWebClient/AccuRouteWebClientInstallConfigGuide.pdf
http://www.omtool.com/documentation/AccuRoute/4.0/CostRecovery/CostRecoveryAdministratorGuide.pdf
http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
http://www.omtool.com/documentation/accuroute/4.0/documentation.htm
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7 In the Genifax Server text box, enter the name or the IP address of the system running the 
AccuRoute Server. 

8 Click Next. The Start Copying Files page opens. 

9 Review the installation settings. Click Next to install the CostRecovery client. 

10 When the installation is complete, the InstallShield Wizard Complete page opens. 

11 Click Finish. 

Important Recreate the export template file before running CostRecovery. Additionally, enable the 
Billing component on the AccuRoute Server and configure it to collect the information 
you need. For more information, refer to the Administrator help.

You can recreate older custom configurations in the new Cost Recovery client using the 
backup files. For more information, see Backing up Cost Recovery custom configurations 
(2-8).

12 Check the version of the client to make sure that the upgrade was successful. The version should be 
v3.2.0.1014.

FaxCenter client
When you upgrade your AccuRoute Server, upgrade all instances of the FaxCenter client in your environment. For 
more information on the FaxCenter application, consult the FaxCenter Online Help. 

To upgrade FaxCenter:

1 Click Start > Control Panel > Add/Remove Programs. Remove the existing version of 
FaxCenter from the system.

2 Open Windows Explorer and navigate to \\Servername\Clients\FaxCenter. 

where Clients is the network share folder containing the installation setup files. You must have 
configured this folder to give everyone access to the folder.

3 Run setup.exe. 

The InstallShield Wizard configures the system for the FaxCenter client and the Welcome message 
appears. 

4 Click Next. The License Agreement page opens. 

5 Read the license agreement. Click Yes. The Choose Destination Location page opens. 

6 Click Next to accept the default destination location. Alternately, to install the application in a 
different location, click Browse. Navigate to the desired directory. Click OK and then Next.

The Start Copying Files page opens. 

7 Review the installation settings. Click Next to install the FaxCenter client. 

8 When installation is complete, the InstallShield Wizard Complete page opens. 

9 Click Finish. 

http://www.omtool.com/omtoolserver/v331/documentation/faxcenter/index.htm
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10 Check the version of the client to make sure that the upgrade was successful. The version should be 
v3.6.

AccuRoute Desktop client
The following version of the AccuRoute Desktop is qualified with AccuRoute v4.0.

 AccuRoute Desktop v4.0 (ships with AccuRoute v4.0)

Note While the legacy AccuRoute Desktops are supported, Omtool recommends that you upgrade to the latest 
version of AccuRoute Desktop client to take advantage of the latest features. AccuRoute Desktop clients 
prior to v3.01 are not supported. 

For more information on the AccuRoute Desktop client, consult the Install Guide and the User Guide. 

To upgrade the AccuRoute Desktop client:

1 Log in to the system where you have the client using an account that belongs to the local 
Administrators group.

2 Open Windows Explorer and navigate to \\Servername\Clients\AccuRouteDesktop. 

where Clients is the network share folder containing the installation setup files. You must have 
configured this folder to give everyone access to the folder.

3 Run setup.exe. 

The InstallShield Wizard configures the system and the Welcome message appears. 

4 Click Next. The License Agreement page opens. 

5 Read the license agreement. Select the I accept the terms in the license agreement option and 
click Next. 

The Destination Folder page opens. 

6 Click Next to accept the default destination location. Alternately, to install the application in a 
different location, click Browse. Navigate to the desired directory. Click OK and then Next.

The Ready to Install page opens. 

7 Click Install to begin the installation. 

When installation is complete, the InstallShield Wizard Complete page opens. 

8 Click Finish. 

9 Check the version of the client to make sure that the upgrade was successful. The version should be 
v4.0.

http://www.omtool.com/documentation/AccuRoute/4.0/AccuRouteDesktop/AccuRouteDesktopInstallGuide.pdf
http://www.omtool.com/documentation/AccuRoute/4.0/AccuRouteDesktop/AccuRouteDesktopUserGuide.pdf
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Image-In Queue client
When you upgrade your AccuRoute Server, upgrade all instances of the Image-In Queue client in your environment. 
For more information on the Image-In Queue client, consult the Install Guide and the User Guide.

To upgrade the Image-In Queue client:

1 Log in to the system where you have the client using an account that belongs to the local 
Administrators group.

2 Open Windows Explorer and navigate to \\Servername\Clients\Image-In Queue. 

where Clients is the network share folder containing the installation setup files. You must have 
configured this folder to give everyone access to the folder.

3 Run setup.exe. 

The InstallShield Wizard configures the system and the Welcome message appears. 

4 Click Next. The setup shows the license agreement. 

5 Read the agreement carefully and if you agree to the terms, click Yes. 

The Choose Destination Folder page opens. The default destination is C:\Program 
Files\Omtool\Image-In Queue.

6 Click Next to select the default destination. The Start Copying Files page lists installation details 
you have supplied. If you want to install in a non-default location, click Browse, select the location and 
then click Next. 

7 Click Next to begin the installation. When the installation is complete, the InstallShield Wizard 
Complete message appears. 

8 Click Finish to close the wizard. 

9 Check the version of the client to make sure that the upgrade was successful. The version should be 
v4.0.

http://www.omtool.com/documentation/AccuRoute/4.0/IIQ/IIQInstallGuide.pdf
http://www.omtool.com/documentation/AccuRoute/4.0/IIQ/UserHelp/WebHelp/IIQHelp.htm
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Section 7: Troubleshooting

This section includes:

Preview and Approval links from AccuRoute Web Client v1.0 become unusable after upgrading (7-1)

Preview and Approval links from AccuRoute Web Client 
v1.0 become unusable after upgrading 
Problem:

I upgraded from AccuRoute Web Client v1.0 to v2.0 (or later version). Approval and Preview links from v1.0 are 
now unusable.

Solution:

After you upgrade from an older Web Client (AccuRoute Web Client v1.0 ), the older web client is uninstalled. As 
a result, there is no control on the process of redirection. Use the sample ASP file below to redirect the old Web 
Client requests to new Web Client location. 

Note For this workaround to be effective, verify the job id is the same in the old AccuRoute Server and the 
upgraded new AccuRoute Server. If the old url has jobid=40 and new url has jobid=65 after the upgrade, 
this workaround will not work. 

To redirect links:

1 Create a virtual directory in IIS with old web client name which is omtool.

For instructions on how to create a virtual directory in IIS, see
http://support.microsoft.com/kb/172138.

2 If old web client name was GenifaxWeb then create the virtual directory with that name.

3 Place the ASP file inside that virtual directory.

Note By default the new web client virtual directory name is "OmtoolArWeb", if it is something different then 
edit the code below to change it (sDestinationVirtualDirectory).

This assumes the new and old web client are on same server, if not change the server name. This page 
will redirect old web client "approval" & "review" requests to new web client.

ASP file

<%@ Language=VBScript %>

<%

' What this page does

http://support.microsoft.com/kb/172138
http://support.microsoft.com/kb/172138
http://support.microsoft.com/kb/172138
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'

' This page allows the user to redirect the request from Old web client to New 
web client

'

' How to install and use it

'

' 1) Create a virtual directory on IIS with old web client name which is "omtool"

' 2) If old web client name was "GenifaxWeb" then create the virtual directory 
with that name

' 3) Place this file inside that virtual directory

' 4) By default the new web client virtual directory name is "OmtoolArWeb", if 
it is something 

'    different then edit the code below to change it 
(sDestinationVirtualDirectory)

' 5) This assumes the new and old web client are on same server, if not change 
the (sServerName)

' 6) This page will redirect old web client "approval" & "review" requests to 
new web client.

dim sUrl

dim sDestinationUrl

dim sServerName

dim sDestinationVirtualDirectory

sServerName = Request.ServerVariables("SERVER_NAME")

sDestinationVirtualDirectory = "OmtoolArWeb"

sDestinationUrl = "http://" & sServerName & "/" & sDestinationVirtualDirectory 
& "/omreviewfax.aspx"

sUrl = Request.ServerVariables("QUERY_STRING")

Response.Redirect sDestinationUrl & "?" & sUrl

%>
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Appendix: Upgrading AccuRoute Servers 
in a Cluster

When upgrading AccuRoute Servers that are part of a server cluster, follow the instructions in this section. 

This section includes:

Upgrading an AccuRoute Server cluster (A-1)

Cancelling out of the server configuration wizard when upgrading the secondary server (A-2)

Error after upgrading the secondary server (A-2)

Using AccuRoute Connector for Lotus Notes in a cluster (A-3)

Upgrading an AccuRoute Server cluster
1 Verify that there are no messages in the In Process queue. If there are, you must cancel the messages 

using the instructions in Cancelling messages in the In Process Queue (2-5). You can resend the 
messages after the upgrade is complete. 

2 Shutdown the secondary server of the cluster.

3 Upgrade the primary server using instructions in Upgrading the AccuRoute Server (3-1).

4 Shutdown the primary server. 

5 Start the secondary server of the cluster. 

6 Upgrade the secondary servers of the cluster using instructions in Upgrading the AccuRoute Server 
(3-1).

Important At the end of the upgrade on the secondary server, when the Server configuration wizard 
appears, you must cancel out of it. For instructions, see Cancelling out of the server 
configuration wizard when upgrading the secondary server (A-2).

If you see the error message “Failed to connect to the server ....”, troubleshoot the 
situation using the instructions in Error after upgrading the secondary server (A-2).

7 Start the primary server. 
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Cancelling out of the server configuration wizard when upgrading the 
secondary server

1 Click Cancel in the Server Configuration Wizard Welcome page.

2 You are prompted to confirm that you want to cancel out of the configuration. 

3 Click Yes. The following dialog opens asking if you want to configure the system the next time you 
start the Administrator. 

4 Click No.

Error after upgrading the secondary server
After you upgrade the secondary server, if the server configuration wizard fails to open and you see the error 
message: “Failed to connect to server. The service cannot be started, either 
because it is disabled or because it has no enabled devices associated with it”

follow the steps below to restart the services and complete the cluster upgrade.

1 In the message “Failed to connect to ...”, click OK.

In the Specify Omtool Message Server dialog, the server name is pre-populated with the name of 
the secondary server you upgraded. 

2 Click Finish. The message “Failed to connect to ...” appears again. 
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3 Repeat steps 1 and 2.

All services are started and the cluster upgrade is successful. 

Using AccuRoute Connector for Lotus Notes in a cluster
If you are using the AccuRoute Connector for Lotus Notes in a cluster environment, all communication between the 
Lotus Notes server and the AccuRoute server is directed through the AccuRoute Connector for SMTP.
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